CVE-2024-3204

CVSS v3 7.3 (High)
CVSS v2 7.5 (High)
EPSS 0.04 % (14th)

A vulnerability has been found in c-blosc2 up to 2.13.2 and classified as critical. Affected by this vulnerability is the function ndlz4_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz4x4.c. The manipulation leads to heap-based buffer overflow. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-259051.

Weaknesses
CWE-122
Heap-based Buffer Overflow
CNA
VulDB
cna@vuldb.com
Published Date
2024-04-02 22:15:11
(3 weeks ago)
Updated Date
2024-04-11 01:25:55
(13 days ago)
Loading...
Loading...
Loading...
Loading...
Loading...
Loading...
Loading...
Loading...