[RHSA-2024:3838] ruby security update

Severity Moderate
Affected Packages 46
CVEs 6

Ruby is an extensible, interpreted, object-oriented, scripting language. It has features to process text files and to perform system management tasks.

The following packages have been upgraded to a later upstream version: ruby
(3.0). (RHEL-35740)

Security Fix(es):

  • ruby/cgi-gem: HTTP response splitting in CGI (CVE-2021-33621)

  • ruby: ReDoS vulnerability in URI (CVE-2023-28755)

  • ruby: ReDoS vulnerability in Time (CVE-2023-28756)

  • ruby: Buffer overread vulnerability in StringIO (CVE-2024-27280)

  • ruby: RCE vulnerability with .rdoc_options in RDoc (CVE-2024-27281)

  • ruby: Arbitrary memory address read vulnerability with Regex search (CVE-2024-27282)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Package Affected Version
pkg:rpm/redhat/rubygems?distro=redhat-9.4 < 3.2.33-162.el9_4
pkg:rpm/redhat/rubygems-devel?distro=redhat-9.4 < 3.2.33-162.el9_4
pkg:rpm/redhat/rubygem-typeprof?distro=redhat-9.4 < 0.15.2-162.el9_4
pkg:rpm/redhat/rubygem-test-unit?distro=redhat-9.4 < 3.3.7-162.el9_4
pkg:rpm/redhat/rubygem-rss?distro=redhat-9.4 < 0.2.9-162.el9_4
pkg:rpm/redhat/rubygem-rexml?distro=redhat-9.4 < 3.2.5-162.el9_4
pkg:rpm/redhat/rubygem-rdoc?distro=redhat-9.4 < 6.3.4.1-162.el9_4
pkg:rpm/redhat/rubygem-rbs?distro=redhat-9.4 < 1.4.0-162.el9_4
pkg:rpm/redhat/rubygem-rake?distro=redhat-9.4 < 13.0.3-162.el9_4
pkg:rpm/redhat/rubygem-psych?arch=x86_64&distro=redhat-9.4 < 3.3.2-162.el9_4
pkg:rpm/redhat/rubygem-psych?arch=s390x&distro=redhat-9.4 < 3.3.2-162.el9_4
pkg:rpm/redhat/rubygem-psych?arch=ppc64le&distro=redhat-9.4 < 3.3.2-162.el9_4
pkg:rpm/redhat/rubygem-psych?arch=aarch64&distro=redhat-9.4 < 3.3.2-162.el9_4
pkg:rpm/redhat/rubygem-power_assert?distro=redhat-9.4 < 1.2.1-162.el9_4
pkg:rpm/redhat/rubygem-minitest?distro=redhat-9.4 < 5.14.2-162.el9_4
pkg:rpm/redhat/rubygem-json?arch=x86_64&distro=redhat-9.4 < 2.5.1-162.el9_4
pkg:rpm/redhat/rubygem-json?arch=s390x&distro=redhat-9.4 < 2.5.1-162.el9_4
pkg:rpm/redhat/rubygem-json?arch=ppc64le&distro=redhat-9.4 < 2.5.1-162.el9_4
pkg:rpm/redhat/rubygem-json?arch=aarch64&distro=redhat-9.4 < 2.5.1-162.el9_4
pkg:rpm/redhat/rubygem-irb?distro=redhat-9.4 < 1.3.5-162.el9_4
pkg:rpm/redhat/rubygem-io-console?arch=x86_64&distro=redhat-9.4 < 0.5.7-162.el9_4
pkg:rpm/redhat/rubygem-io-console?arch=s390x&distro=redhat-9.4 < 0.5.7-162.el9_4
pkg:rpm/redhat/rubygem-io-console?arch=ppc64le&distro=redhat-9.4 < 0.5.7-162.el9_4
pkg:rpm/redhat/rubygem-io-console?arch=aarch64&distro=redhat-9.4 < 0.5.7-162.el9_4
pkg:rpm/redhat/rubygem-bundler?distro=redhat-9.4 < 2.2.33-162.el9_4
pkg:rpm/redhat/rubygem-bigdecimal?arch=x86_64&distro=redhat-9.4 < 3.0.0-162.el9_4
pkg:rpm/redhat/rubygem-bigdecimal?arch=s390x&distro=redhat-9.4 < 3.0.0-162.el9_4
pkg:rpm/redhat/rubygem-bigdecimal?arch=ppc64le&distro=redhat-9.4 < 3.0.0-162.el9_4
pkg:rpm/redhat/rubygem-bigdecimal?arch=aarch64&distro=redhat-9.4 < 3.0.0-162.el9_4
pkg:rpm/redhat/ruby?arch=x86_64&distro=redhat-9.4 < 3.0.7-162.el9_4
pkg:rpm/redhat/ruby?arch=s390x&distro=redhat-9.4 < 3.0.7-162.el9_4
pkg:rpm/redhat/ruby?arch=ppc64le&distro=redhat-9.4 < 3.0.7-162.el9_4
pkg:rpm/redhat/ruby?arch=i686&distro=redhat-9.4 < 3.0.7-162.el9_4
pkg:rpm/redhat/ruby?arch=aarch64&distro=redhat-9.4 < 3.0.7-162.el9_4
pkg:rpm/redhat/ruby-libs?arch=x86_64&distro=redhat-9.4 < 3.0.7-162.el9_4
pkg:rpm/redhat/ruby-libs?arch=s390x&distro=redhat-9.4 < 3.0.7-162.el9_4
pkg:rpm/redhat/ruby-libs?arch=ppc64le&distro=redhat-9.4 < 3.0.7-162.el9_4
pkg:rpm/redhat/ruby-libs?arch=i686&distro=redhat-9.4 < 3.0.7-162.el9_4
pkg:rpm/redhat/ruby-libs?arch=aarch64&distro=redhat-9.4 < 3.0.7-162.el9_4
pkg:rpm/redhat/ruby-doc?distro=redhat-9.4 < 3.0.7-162.el9_4
pkg:rpm/redhat/ruby-devel?arch=x86_64&distro=redhat-9.4 < 3.0.7-162.el9_4
pkg:rpm/redhat/ruby-devel?arch=s390x&distro=redhat-9.4 < 3.0.7-162.el9_4
pkg:rpm/redhat/ruby-devel?arch=ppc64le&distro=redhat-9.4 < 3.0.7-162.el9_4
pkg:rpm/redhat/ruby-devel?arch=i686&distro=redhat-9.4 < 3.0.7-162.el9_4
pkg:rpm/redhat/ruby-devel?arch=aarch64&distro=redhat-9.4 < 3.0.7-162.el9_4
pkg:rpm/redhat/ruby-default-gems?distro=redhat-9.4 < 3.0.7-162.el9_4
Type Package URL Namespace Name / Product Version Distribution / Platform Arch Patch / Fix
Affected pkg:rpm/redhat/rubygems?distro=redhat-9.4 redhat rubygems < 3.2.33-162.el9_4 redhat-9.4
Affected pkg:rpm/redhat/rubygems-devel?distro=redhat-9.4 redhat rubygems-devel < 3.2.33-162.el9_4 redhat-9.4
Affected pkg:rpm/redhat/rubygem-typeprof?distro=redhat-9.4 redhat rubygem-typeprof < 0.15.2-162.el9_4 redhat-9.4
Affected pkg:rpm/redhat/rubygem-test-unit?distro=redhat-9.4 redhat rubygem-test-unit < 3.3.7-162.el9_4 redhat-9.4
Affected pkg:rpm/redhat/rubygem-rss?distro=redhat-9.4 redhat rubygem-rss < 0.2.9-162.el9_4 redhat-9.4
Affected pkg:rpm/redhat/rubygem-rexml?distro=redhat-9.4 redhat rubygem-rexml < 3.2.5-162.el9_4 redhat-9.4
Affected pkg:rpm/redhat/rubygem-rdoc?distro=redhat-9.4 redhat rubygem-rdoc < 6.3.4.1-162.el9_4 redhat-9.4
Affected pkg:rpm/redhat/rubygem-rbs?distro=redhat-9.4 redhat rubygem-rbs < 1.4.0-162.el9_4 redhat-9.4
Affected pkg:rpm/redhat/rubygem-rake?distro=redhat-9.4 redhat rubygem-rake < 13.0.3-162.el9_4 redhat-9.4
Affected pkg:rpm/redhat/rubygem-psych?arch=x86_64&distro=redhat-9.4 redhat rubygem-psych < 3.3.2-162.el9_4 redhat-9.4 x86_64
Affected pkg:rpm/redhat/rubygem-psych?arch=s390x&distro=redhat-9.4 redhat rubygem-psych < 3.3.2-162.el9_4 redhat-9.4 s390x
Affected pkg:rpm/redhat/rubygem-psych?arch=ppc64le&distro=redhat-9.4 redhat rubygem-psych < 3.3.2-162.el9_4 redhat-9.4 ppc64le
Affected pkg:rpm/redhat/rubygem-psych?arch=aarch64&distro=redhat-9.4 redhat rubygem-psych < 3.3.2-162.el9_4 redhat-9.4 aarch64
Affected pkg:rpm/redhat/rubygem-power_assert?distro=redhat-9.4 redhat rubygem-power_assert < 1.2.1-162.el9_4 redhat-9.4
Affected pkg:rpm/redhat/rubygem-minitest?distro=redhat-9.4 redhat rubygem-minitest < 5.14.2-162.el9_4 redhat-9.4
Affected pkg:rpm/redhat/rubygem-json?arch=x86_64&distro=redhat-9.4 redhat rubygem-json < 2.5.1-162.el9_4 redhat-9.4 x86_64
Affected pkg:rpm/redhat/rubygem-json?arch=s390x&distro=redhat-9.4 redhat rubygem-json < 2.5.1-162.el9_4 redhat-9.4 s390x
Affected pkg:rpm/redhat/rubygem-json?arch=ppc64le&distro=redhat-9.4 redhat rubygem-json < 2.5.1-162.el9_4 redhat-9.4 ppc64le
Affected pkg:rpm/redhat/rubygem-json?arch=aarch64&distro=redhat-9.4 redhat rubygem-json < 2.5.1-162.el9_4 redhat-9.4 aarch64
Affected pkg:rpm/redhat/rubygem-irb?distro=redhat-9.4 redhat rubygem-irb < 1.3.5-162.el9_4 redhat-9.4
Affected pkg:rpm/redhat/rubygem-io-console?arch=x86_64&distro=redhat-9.4 redhat rubygem-io-console < 0.5.7-162.el9_4 redhat-9.4 x86_64
Affected pkg:rpm/redhat/rubygem-io-console?arch=s390x&distro=redhat-9.4 redhat rubygem-io-console < 0.5.7-162.el9_4 redhat-9.4 s390x
Affected pkg:rpm/redhat/rubygem-io-console?arch=ppc64le&distro=redhat-9.4 redhat rubygem-io-console < 0.5.7-162.el9_4 redhat-9.4 ppc64le
Affected pkg:rpm/redhat/rubygem-io-console?arch=aarch64&distro=redhat-9.4 redhat rubygem-io-console < 0.5.7-162.el9_4 redhat-9.4 aarch64
Affected pkg:rpm/redhat/rubygem-bundler?distro=redhat-9.4 redhat rubygem-bundler < 2.2.33-162.el9_4 redhat-9.4
Affected pkg:rpm/redhat/rubygem-bigdecimal?arch=x86_64&distro=redhat-9.4 redhat rubygem-bigdecimal < 3.0.0-162.el9_4 redhat-9.4 x86_64
Affected pkg:rpm/redhat/rubygem-bigdecimal?arch=s390x&distro=redhat-9.4 redhat rubygem-bigdecimal < 3.0.0-162.el9_4 redhat-9.4 s390x
Affected pkg:rpm/redhat/rubygem-bigdecimal?arch=ppc64le&distro=redhat-9.4 redhat rubygem-bigdecimal < 3.0.0-162.el9_4 redhat-9.4 ppc64le
Affected pkg:rpm/redhat/rubygem-bigdecimal?arch=aarch64&distro=redhat-9.4 redhat rubygem-bigdecimal < 3.0.0-162.el9_4 redhat-9.4 aarch64
Affected pkg:rpm/redhat/ruby?arch=x86_64&distro=redhat-9.4 redhat ruby < 3.0.7-162.el9_4 redhat-9.4 x86_64
Affected pkg:rpm/redhat/ruby?arch=s390x&distro=redhat-9.4 redhat ruby < 3.0.7-162.el9_4 redhat-9.4 s390x
Affected pkg:rpm/redhat/ruby?arch=ppc64le&distro=redhat-9.4 redhat ruby < 3.0.7-162.el9_4 redhat-9.4 ppc64le
Affected pkg:rpm/redhat/ruby?arch=i686&distro=redhat-9.4 redhat ruby < 3.0.7-162.el9_4 redhat-9.4 i686
Affected pkg:rpm/redhat/ruby?arch=aarch64&distro=redhat-9.4 redhat ruby < 3.0.7-162.el9_4 redhat-9.4 aarch64
Affected pkg:rpm/redhat/ruby-libs?arch=x86_64&distro=redhat-9.4 redhat ruby-libs < 3.0.7-162.el9_4 redhat-9.4 x86_64
Affected pkg:rpm/redhat/ruby-libs?arch=s390x&distro=redhat-9.4 redhat ruby-libs < 3.0.7-162.el9_4 redhat-9.4 s390x
Affected pkg:rpm/redhat/ruby-libs?arch=ppc64le&distro=redhat-9.4 redhat ruby-libs < 3.0.7-162.el9_4 redhat-9.4 ppc64le
Affected pkg:rpm/redhat/ruby-libs?arch=i686&distro=redhat-9.4 redhat ruby-libs < 3.0.7-162.el9_4 redhat-9.4 i686
Affected pkg:rpm/redhat/ruby-libs?arch=aarch64&distro=redhat-9.4 redhat ruby-libs < 3.0.7-162.el9_4 redhat-9.4 aarch64
Affected pkg:rpm/redhat/ruby-doc?distro=redhat-9.4 redhat ruby-doc < 3.0.7-162.el9_4 redhat-9.4
Affected pkg:rpm/redhat/ruby-devel?arch=x86_64&distro=redhat-9.4 redhat ruby-devel < 3.0.7-162.el9_4 redhat-9.4 x86_64
Affected pkg:rpm/redhat/ruby-devel?arch=s390x&distro=redhat-9.4 redhat ruby-devel < 3.0.7-162.el9_4 redhat-9.4 s390x
Affected pkg:rpm/redhat/ruby-devel?arch=ppc64le&distro=redhat-9.4 redhat ruby-devel < 3.0.7-162.el9_4 redhat-9.4 ppc64le
Affected pkg:rpm/redhat/ruby-devel?arch=i686&distro=redhat-9.4 redhat ruby-devel < 3.0.7-162.el9_4 redhat-9.4 i686
Affected pkg:rpm/redhat/ruby-devel?arch=aarch64&distro=redhat-9.4 redhat ruby-devel < 3.0.7-162.el9_4 redhat-9.4 aarch64
Affected pkg:rpm/redhat/ruby-default-gems?distro=redhat-9.4 redhat ruby-default-gems < 3.0.7-162.el9_4 redhat-9.4
# CVE Description CVSS EPSS EPSS Trend (30 days) Affected Products Weaknesses Security Advisories Exploits PoC Pubblication Date Modification Date
# CVE Description CVSS EPSS EPSS Trend (30 days) Affected Products Weaknesses Security Advisories PoC Pubblication Date Modification Date
Loading...