[ELSA-2024-3668] ruby:3.1 security, bug fix, and enhancement update

Severity Moderate
Affected Packages 27
CVEs 3

ruby
[3.1.5-144]
- Upgrade to Ruby 3.1.5.
Resolves: RHEL-33978
- Fix buffer overread vulnerability in StringIO.
Resolves: RHEL-34129
- Fix RCE vulnerability with .rdoc_options in RDoc.
Resolves: RHEL-34121
- Fix arbitrary memory address read vulnerability with Regex search.
Resolves: RHEL-33871

[3.1.4-143]
- Upgrade to Ruby 3.1.4.
Resolves: RHEL-5586
- Fix HTTP response splitting in CGI.
Resolves: RHEL-5591
- Fix ReDos vulnerability in URI.
Resolves: RHEL-28919
Resolves: RHEL-5612
- Fix ReDos vulnerability in Time.
Resolves: RHEL-28920
- Make RDoc soft dependency in IRB.
Resolves: RHEL-5613

[3.1.2-142]
- Bypass git submodule test failure on Git >= 2.38.1.
- Fix tests with Europe/Amsterdam pre-1970 time on tzdata version 2022b.
- Fix for tzdata-2022g.
- Fix OpenSSL.fips_mode and OpenSSL::PKey.read in OpenSSL 3 FIPS.
Resolves: RHEL-5590
- ssl: use ffdhe2048 from RFC 7919 as the default DH group parameters
Related: RHEL-5590
- Disable fiddle tests that use FFI closures.
Related: RHEL-5590

[3.1.2-141]
- Upgrade to Ruby 3.1.2 by merging Fedora Rawhide branch (commit: b7b5473).
Resolves: rhbz#2063773

rubygem-mysql2
[0.5.4-1]
- New upstream release 0.5.4 by merging Fedora rawhide branch (commit: e21b5b9)
Resolves: rhbz#2063773

[0.5.3-1]
- New upstream release 0.5.3 by merging Fedora master branch (commit: 674d475)
Resolves: rhbz#1817135

rubygem-pg
* Thu May 26 2022 Jarek Prokop - 1.3.5-1
- Update to pg 1.3.5
Related: rhbz#2063773

[1.2.3-1]
- Update to pg 1.2.3 by merging Fedora master branch (commit: 5db4d26)
Resolves: rhbz#1817135

Package Affected Version
pkg:rpm/oraclelinux/rubygems?distro=oraclelinux-9.4 < 3.3.27-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/rubygems-devel?distro=oraclelinux-9.4 < 3.3.27-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/rubygem-typeprof?distro=oraclelinux-9.4 < 0.21.3-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/rubygem-test-unit?distro=oraclelinux-9.4 < 3.5.3-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/rubygem-rss?distro=oraclelinux-9.4 < 0.2.9-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/rubygem-rexml?distro=oraclelinux-9.4 < 3.2.5-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/rubygem-rdoc?distro=oraclelinux-9.4 < 6.4.1.1-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/rubygem-rbs?distro=oraclelinux-9.4 < 2.7.0-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/rubygem-rake?distro=oraclelinux-9.4 < 13.0.6-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/rubygem-psych?distro=oraclelinux-9.4 < 4.0.4-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/rubygem-power_assert?distro=oraclelinux-9.4 < 2.0.1-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/rubygem-pg?distro=oraclelinux-9.1 < 1.3.5-1.module+el9.1.0+20815+286161bd
pkg:rpm/oraclelinux/rubygem-pg-doc?distro=oraclelinux-9.1 < 1.3.5-1.module+el9.1.0+20815+286161bd
pkg:rpm/oraclelinux/rubygem-mysql2?distro=oraclelinux-9.1 < 0.5.4-1.module+el9.1.0+20815+286161bd
pkg:rpm/oraclelinux/rubygem-mysql2-doc?distro=oraclelinux-9.1 < 0.5.4-1.module+el9.1.0+20815+286161bd
pkg:rpm/oraclelinux/rubygem-minitest?distro=oraclelinux-9.4 < 5.15.0-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/rubygem-json?distro=oraclelinux-9.4 < 2.6.1-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/rubygem-irb?distro=oraclelinux-9.4 < 1.4.1-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/rubygem-io-console?distro=oraclelinux-9.4 < 0.5.11-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/rubygem-bundler?distro=oraclelinux-9.4 < 2.3.27-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/rubygem-bigdecimal?distro=oraclelinux-9.4 < 3.1.1-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/ruby?distro=oraclelinux-9.4 < 3.1.5-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/ruby-libs?distro=oraclelinux-9.4 < 3.1.5-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/ruby-doc?distro=oraclelinux-9.4 < 3.1.5-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/ruby-devel?distro=oraclelinux-9.4 < 3.1.5-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/ruby-default-gems?distro=oraclelinux-9.4 < 3.1.5-144.module+el9.4.0+90348+c2ef46bf
pkg:rpm/oraclelinux/ruby-bundled-gems?distro=oraclelinux-9.4 < 3.1.5-144.module+el9.4.0+90348+c2ef46bf
Type Package URL Namespace Name / Product Version Distribution / Platform Arch Patch / Fix
Affected pkg:rpm/oraclelinux/rubygems?distro=oraclelinux-9.4 oraclelinux rubygems < 3.3.27-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/rubygems-devel?distro=oraclelinux-9.4 oraclelinux rubygems-devel < 3.3.27-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/rubygem-typeprof?distro=oraclelinux-9.4 oraclelinux rubygem-typeprof < 0.21.3-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/rubygem-test-unit?distro=oraclelinux-9.4 oraclelinux rubygem-test-unit < 3.5.3-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/rubygem-rss?distro=oraclelinux-9.4 oraclelinux rubygem-rss < 0.2.9-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/rubygem-rexml?distro=oraclelinux-9.4 oraclelinux rubygem-rexml < 3.2.5-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/rubygem-rdoc?distro=oraclelinux-9.4 oraclelinux rubygem-rdoc < 6.4.1.1-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/rubygem-rbs?distro=oraclelinux-9.4 oraclelinux rubygem-rbs < 2.7.0-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/rubygem-rake?distro=oraclelinux-9.4 oraclelinux rubygem-rake < 13.0.6-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/rubygem-psych?distro=oraclelinux-9.4 oraclelinux rubygem-psych < 4.0.4-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/rubygem-power_assert?distro=oraclelinux-9.4 oraclelinux rubygem-power_assert < 2.0.1-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/rubygem-pg?distro=oraclelinux-9.1 oraclelinux rubygem-pg < 1.3.5-1.module+el9.1.0+20815+286161bd oraclelinux-9.1
Affected pkg:rpm/oraclelinux/rubygem-pg-doc?distro=oraclelinux-9.1 oraclelinux rubygem-pg-doc < 1.3.5-1.module+el9.1.0+20815+286161bd oraclelinux-9.1
Affected pkg:rpm/oraclelinux/rubygem-mysql2?distro=oraclelinux-9.1 oraclelinux rubygem-mysql2 < 0.5.4-1.module+el9.1.0+20815+286161bd oraclelinux-9.1
Affected pkg:rpm/oraclelinux/rubygem-mysql2-doc?distro=oraclelinux-9.1 oraclelinux rubygem-mysql2-doc < 0.5.4-1.module+el9.1.0+20815+286161bd oraclelinux-9.1
Affected pkg:rpm/oraclelinux/rubygem-minitest?distro=oraclelinux-9.4 oraclelinux rubygem-minitest < 5.15.0-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/rubygem-json?distro=oraclelinux-9.4 oraclelinux rubygem-json < 2.6.1-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/rubygem-irb?distro=oraclelinux-9.4 oraclelinux rubygem-irb < 1.4.1-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/rubygem-io-console?distro=oraclelinux-9.4 oraclelinux rubygem-io-console < 0.5.11-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/rubygem-bundler?distro=oraclelinux-9.4 oraclelinux rubygem-bundler < 2.3.27-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/rubygem-bigdecimal?distro=oraclelinux-9.4 oraclelinux rubygem-bigdecimal < 3.1.1-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/ruby?distro=oraclelinux-9.4 oraclelinux ruby < 3.1.5-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/ruby-libs?distro=oraclelinux-9.4 oraclelinux ruby-libs < 3.1.5-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/ruby-doc?distro=oraclelinux-9.4 oraclelinux ruby-doc < 3.1.5-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/ruby-devel?distro=oraclelinux-9.4 oraclelinux ruby-devel < 3.1.5-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/ruby-default-gems?distro=oraclelinux-9.4 oraclelinux ruby-default-gems < 3.1.5-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
Affected pkg:rpm/oraclelinux/ruby-bundled-gems?distro=oraclelinux-9.4 oraclelinux ruby-bundled-gems < 3.1.5-144.module+el9.4.0+90348+c2ef46bf oraclelinux-9.4
# CVE Description CVSS EPSS EPSS Trend (30 days) Affected Products Weaknesses Security Advisories Exploits PoC Pubblication Date Modification Date
# CVE Description CVSS EPSS EPSS Trend (30 days) Affected Products Weaknesses Security Advisories PoC Pubblication Date Modification Date
Loading...