[ALSA-2024:3546] ruby:3.1 security, bug fix, and enhancement update

Severity Moderate
Affected Packages 49
CVEs 3

ruby:3.1 security, bug fix, and enhancement update

Ruby is an extensible, interpreted, object-oriented, scripting language. It has features to process text files and to perform system management tasks.

Security Fix(es):

  • ruby: RCE vulnerability with .rdoc_options in RDoc (CVE-2024-27281)
  • ruby: Buffer overread vulnerability in StringIO (CVE-2024-27280)
  • ruby: Arbitrary memory address read vulnerability with Regex search (CVE-2024-27282)

For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.

Package Affected Version
pkg:rpm/almalinux/rubygems?arch=noarch&distro=almalinux-8.1 < 3.3.27-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygems-devel?arch=noarch&distro=almalinux-8.1 < 3.3.27-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-typeprof?arch=noarch&distro=almalinux-8.1 < 0.21.3-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-test-unit?arch=noarch&distro=almalinux-8.1 < 3.5.3-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-rss?arch=noarch&distro=almalinux-8.1 < 0.2.9-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-rexml?arch=noarch&distro=almalinux-8.1 < 3.2.5-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-rdoc?arch=noarch&distro=almalinux-8.1 < 6.4.1.1-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-rbs?arch=x86_64&distro=almalinux-8.1 < 2.7.0-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-rbs?arch=i686&distro=almalinux-8.1 < 2.7.0-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-rbs?arch=aarch64&distro=almalinux-8.1 < 2.7.0-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-rake?arch=noarch&distro=almalinux-8.1 < 13.0.6-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-psych?arch=x86_64&distro=almalinux-8.1 < 4.0.4-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-psych?arch=i686&distro=almalinux-8.1 < 4.0.4-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-psych?arch=aarch64&distro=almalinux-8.1 < 4.0.4-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-power_assert?arch=noarch&distro=almalinux-8.1 < 2.0.1-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-pg?arch=x86_64&distro=almalinux-8.9 < 1.3.2-1.module_el8.9.0+3746+91b8233a
pkg:rpm/almalinux/rubygem-pg?arch=aarch64&distro=almalinux-8.9 < 1.3.2-1.module_el8.9.0+3746+91b8233a
pkg:rpm/almalinux/rubygem-pg-doc?arch=noarch&distro=almalinux-8.9 < 1.3.2-1.module_el8.9.0+3746+91b8233a
pkg:rpm/almalinux/rubygem-mysql2?arch=x86_64&distro=almalinux-8.9 < 0.5.3-3.module_el8.9.0+3746+91b8233a
pkg:rpm/almalinux/rubygem-mysql2?arch=aarch64&distro=almalinux-8.9 < 0.5.3-3.module_el8.9.0+3746+91b8233a
pkg:rpm/almalinux/rubygem-mysql2-doc?arch=noarch&distro=almalinux-8.9 < 0.5.3-3.module_el8.9.0+3746+91b8233a
pkg:rpm/almalinux/rubygem-minitest?arch=noarch&distro=almalinux-8.1 < 5.15.0-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-json?arch=x86_64&distro=almalinux-8.1 < 2.6.1-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-json?arch=i686&distro=almalinux-8.1 < 2.6.1-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-json?arch=aarch64&distro=almalinux-8.1 < 2.6.1-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-irb?arch=noarch&distro=almalinux-8.1 < 1.4.1-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-io-console?arch=x86_64&distro=almalinux-8.1 < 0.5.11-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-io-console?arch=i686&distro=almalinux-8.1 < 0.5.11-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-io-console?arch=aarch64&distro=almalinux-8.1 < 0.5.11-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-bundler?arch=noarch&distro=almalinux-8.1 < 2.3.27-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-bigdecimal?arch=x86_64&distro=almalinux-8.1 < 3.1.1-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-bigdecimal?arch=i686&distro=almalinux-8.1 < 3.1.1-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-bigdecimal?arch=aarch64&distro=almalinux-8.1 < 3.1.1-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/rubygem-abrt?arch=noarch&distro=almalinux-8.9 < 0.4.0-1.module_el8.9.0+3746+91b8233a
pkg:rpm/almalinux/rubygem-abrt-doc?arch=noarch&distro=almalinux-8.9 < 0.4.0-1.module_el8.9.0+3746+91b8233a
pkg:rpm/almalinux/ruby?arch=x86_64&distro=almalinux-8.1 < 3.1.5-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/ruby?arch=i686&distro=almalinux-8.1 < 3.1.5-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/ruby?arch=aarch64&distro=almalinux-8.1 < 3.1.5-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/ruby-libs?arch=x86_64&distro=almalinux-8.1 < 3.1.5-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/ruby-libs?arch=i686&distro=almalinux-8.1 < 3.1.5-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/ruby-libs?arch=aarch64&distro=almalinux-8.1 < 3.1.5-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/ruby-doc?arch=noarch&distro=almalinux-8.1 < 3.1.5-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/ruby-devel?arch=x86_64&distro=almalinux-8.1 < 3.1.5-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/ruby-devel?arch=i686&distro=almalinux-8.1 < 3.1.5-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/ruby-devel?arch=aarch64&distro=almalinux-8.1 < 3.1.5-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/ruby-default-gems?arch=noarch&distro=almalinux-8.1 < 3.1.5-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/ruby-bundled-gems?arch=x86_64&distro=almalinux-8.1 < 3.1.5-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/ruby-bundled-gems?arch=i686&distro=almalinux-8.1 < 3.1.5-143.module_el8.10.0+3854+02eaa59a
pkg:rpm/almalinux/ruby-bundled-gems?arch=aarch64&distro=almalinux-8.1 < 3.1.5-143.module_el8.10.0+3854+02eaa59a
Type Package URL Namespace Name / Product Version Distribution / Platform Arch Patch / Fix
Affected pkg:rpm/almalinux/rubygems?arch=noarch&distro=almalinux-8.1 almalinux rubygems < 3.3.27-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 noarch
Affected pkg:rpm/almalinux/rubygems-devel?arch=noarch&distro=almalinux-8.1 almalinux rubygems-devel < 3.3.27-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 noarch
Affected pkg:rpm/almalinux/rubygem-typeprof?arch=noarch&distro=almalinux-8.1 almalinux rubygem-typeprof < 0.21.3-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 noarch
Affected pkg:rpm/almalinux/rubygem-test-unit?arch=noarch&distro=almalinux-8.1 almalinux rubygem-test-unit < 3.5.3-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 noarch
Affected pkg:rpm/almalinux/rubygem-rss?arch=noarch&distro=almalinux-8.1 almalinux rubygem-rss < 0.2.9-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 noarch
Affected pkg:rpm/almalinux/rubygem-rexml?arch=noarch&distro=almalinux-8.1 almalinux rubygem-rexml < 3.2.5-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 noarch
Affected pkg:rpm/almalinux/rubygem-rdoc?arch=noarch&distro=almalinux-8.1 almalinux rubygem-rdoc < 6.4.1.1-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 noarch
Affected pkg:rpm/almalinux/rubygem-rbs?arch=x86_64&distro=almalinux-8.1 almalinux rubygem-rbs < 2.7.0-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 x86_64
Affected pkg:rpm/almalinux/rubygem-rbs?arch=i686&distro=almalinux-8.1 almalinux rubygem-rbs < 2.7.0-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 i686
Affected pkg:rpm/almalinux/rubygem-rbs?arch=aarch64&distro=almalinux-8.1 almalinux rubygem-rbs < 2.7.0-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 aarch64
Affected pkg:rpm/almalinux/rubygem-rake?arch=noarch&distro=almalinux-8.1 almalinux rubygem-rake < 13.0.6-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 noarch
Affected pkg:rpm/almalinux/rubygem-psych?arch=x86_64&distro=almalinux-8.1 almalinux rubygem-psych < 4.0.4-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 x86_64
Affected pkg:rpm/almalinux/rubygem-psych?arch=i686&distro=almalinux-8.1 almalinux rubygem-psych < 4.0.4-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 i686
Affected pkg:rpm/almalinux/rubygem-psych?arch=aarch64&distro=almalinux-8.1 almalinux rubygem-psych < 4.0.4-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 aarch64
Affected pkg:rpm/almalinux/rubygem-power_assert?arch=noarch&distro=almalinux-8.1 almalinux rubygem-power_assert < 2.0.1-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 noarch
Affected pkg:rpm/almalinux/rubygem-pg?arch=x86_64&distro=almalinux-8.9 almalinux rubygem-pg < 1.3.2-1.module_el8.9.0+3746+91b8233a almalinux-8.9 x86_64
Affected pkg:rpm/almalinux/rubygem-pg?arch=aarch64&distro=almalinux-8.9 almalinux rubygem-pg < 1.3.2-1.module_el8.9.0+3746+91b8233a almalinux-8.9 aarch64
Affected pkg:rpm/almalinux/rubygem-pg-doc?arch=noarch&distro=almalinux-8.9 almalinux rubygem-pg-doc < 1.3.2-1.module_el8.9.0+3746+91b8233a almalinux-8.9 noarch
Affected pkg:rpm/almalinux/rubygem-mysql2?arch=x86_64&distro=almalinux-8.9 almalinux rubygem-mysql2 < 0.5.3-3.module_el8.9.0+3746+91b8233a almalinux-8.9 x86_64
Affected pkg:rpm/almalinux/rubygem-mysql2?arch=aarch64&distro=almalinux-8.9 almalinux rubygem-mysql2 < 0.5.3-3.module_el8.9.0+3746+91b8233a almalinux-8.9 aarch64
Affected pkg:rpm/almalinux/rubygem-mysql2-doc?arch=noarch&distro=almalinux-8.9 almalinux rubygem-mysql2-doc < 0.5.3-3.module_el8.9.0+3746+91b8233a almalinux-8.9 noarch
Affected pkg:rpm/almalinux/rubygem-minitest?arch=noarch&distro=almalinux-8.1 almalinux rubygem-minitest < 5.15.0-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 noarch
Affected pkg:rpm/almalinux/rubygem-json?arch=x86_64&distro=almalinux-8.1 almalinux rubygem-json < 2.6.1-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 x86_64
Affected pkg:rpm/almalinux/rubygem-json?arch=i686&distro=almalinux-8.1 almalinux rubygem-json < 2.6.1-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 i686
Affected pkg:rpm/almalinux/rubygem-json?arch=aarch64&distro=almalinux-8.1 almalinux rubygem-json < 2.6.1-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 aarch64
Affected pkg:rpm/almalinux/rubygem-irb?arch=noarch&distro=almalinux-8.1 almalinux rubygem-irb < 1.4.1-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 noarch
Affected pkg:rpm/almalinux/rubygem-io-console?arch=x86_64&distro=almalinux-8.1 almalinux rubygem-io-console < 0.5.11-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 x86_64
Affected pkg:rpm/almalinux/rubygem-io-console?arch=i686&distro=almalinux-8.1 almalinux rubygem-io-console < 0.5.11-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 i686
Affected pkg:rpm/almalinux/rubygem-io-console?arch=aarch64&distro=almalinux-8.1 almalinux rubygem-io-console < 0.5.11-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 aarch64
Affected pkg:rpm/almalinux/rubygem-bundler?arch=noarch&distro=almalinux-8.1 almalinux rubygem-bundler < 2.3.27-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 noarch
Affected pkg:rpm/almalinux/rubygem-bigdecimal?arch=x86_64&distro=almalinux-8.1 almalinux rubygem-bigdecimal < 3.1.1-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 x86_64
Affected pkg:rpm/almalinux/rubygem-bigdecimal?arch=i686&distro=almalinux-8.1 almalinux rubygem-bigdecimal < 3.1.1-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 i686
Affected pkg:rpm/almalinux/rubygem-bigdecimal?arch=aarch64&distro=almalinux-8.1 almalinux rubygem-bigdecimal < 3.1.1-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 aarch64
Affected pkg:rpm/almalinux/rubygem-abrt?arch=noarch&distro=almalinux-8.9 almalinux rubygem-abrt < 0.4.0-1.module_el8.9.0+3746+91b8233a almalinux-8.9 noarch
Affected pkg:rpm/almalinux/rubygem-abrt-doc?arch=noarch&distro=almalinux-8.9 almalinux rubygem-abrt-doc < 0.4.0-1.module_el8.9.0+3746+91b8233a almalinux-8.9 noarch
Affected pkg:rpm/almalinux/ruby?arch=x86_64&distro=almalinux-8.1 almalinux ruby < 3.1.5-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 x86_64
Affected pkg:rpm/almalinux/ruby?arch=i686&distro=almalinux-8.1 almalinux ruby < 3.1.5-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 i686
Affected pkg:rpm/almalinux/ruby?arch=aarch64&distro=almalinux-8.1 almalinux ruby < 3.1.5-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 aarch64
Affected pkg:rpm/almalinux/ruby-libs?arch=x86_64&distro=almalinux-8.1 almalinux ruby-libs < 3.1.5-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 x86_64
Affected pkg:rpm/almalinux/ruby-libs?arch=i686&distro=almalinux-8.1 almalinux ruby-libs < 3.1.5-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 i686
Affected pkg:rpm/almalinux/ruby-libs?arch=aarch64&distro=almalinux-8.1 almalinux ruby-libs < 3.1.5-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 aarch64
Affected pkg:rpm/almalinux/ruby-doc?arch=noarch&distro=almalinux-8.1 almalinux ruby-doc < 3.1.5-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 noarch
Affected pkg:rpm/almalinux/ruby-devel?arch=x86_64&distro=almalinux-8.1 almalinux ruby-devel < 3.1.5-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 x86_64
Affected pkg:rpm/almalinux/ruby-devel?arch=i686&distro=almalinux-8.1 almalinux ruby-devel < 3.1.5-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 i686
Affected pkg:rpm/almalinux/ruby-devel?arch=aarch64&distro=almalinux-8.1 almalinux ruby-devel < 3.1.5-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 aarch64
Affected pkg:rpm/almalinux/ruby-default-gems?arch=noarch&distro=almalinux-8.1 almalinux ruby-default-gems < 3.1.5-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 noarch
Affected pkg:rpm/almalinux/ruby-bundled-gems?arch=x86_64&distro=almalinux-8.1 almalinux ruby-bundled-gems < 3.1.5-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 x86_64
Affected pkg:rpm/almalinux/ruby-bundled-gems?arch=i686&distro=almalinux-8.1 almalinux ruby-bundled-gems < 3.1.5-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 i686
Affected pkg:rpm/almalinux/ruby-bundled-gems?arch=aarch64&distro=almalinux-8.1 almalinux ruby-bundled-gems < 3.1.5-143.module_el8.10.0+3854+02eaa59a almalinux-8.1 aarch64
# CVE Description CVSS EPSS EPSS Trend (30 days) Affected Products Weaknesses Security Advisories Exploits PoC Pubblication Date Modification Date
# CVE Description CVSS EPSS EPSS Trend (30 days) Affected Products Weaknesses Security Advisories PoC Pubblication Date Modification Date
Loading...